Kampüs network

Merhaba

Kampüs network yada sizin yazının içeriğini okuyarak belirleyebileceğiniz bir başlık altında, dell marka switchler üzerinde (cisco ile komut satırları çok benzer) iki ana omurga, iki ara omurga ve kenar switchlerden oluşan yedekli bir yapının temel kurulumunda kullanılan komut setlerinden bahsetmek istiyorum. Bu yapıda vlanlar oluşturup, bunları birbirleri ile haberleştirecek ve sonrasında bunları istediğimiz portlara atayacağız. Birde ana ve ara omurgalar ile kenar switch leri stack olarak ayarlayacağız. Son olarak ise port channel ile switchlere giren fiber kabloları da yedekli ve yük dengelemeli (load balance) bir hale getireceğiz. Nasıl konu işe yarar değil mi? 🙂 fakat şimdi yemeğim geldi. Buraya kadar ki kısmı telefondan yazdım. Birazdan pc başından yazmaya devam etmeyi düşünüyorum.

1.adım
enable
console#configure
console(config)# vlan 10 ( Vlan 10 oluşturuk)

console(config-if-vlan10)#no ipaaddress (varsa vlan 10 a ait ip adresini kaldırdık) console(config)#interface vlan 10 (vlan 10 içerisine girdik)

console(config-if-vlan10)#ip address 192.168.3.200 255.255.255.0 ( vlan 10 ip adresi verdik, bunu vlan 10 dakiler gateway olarak kullanacak)
console(config-if-vlan10)#interface range gigabitethernet 1/0/1-9 ( vlan 10 üye olacak portlar 1-9)
console(config-if)#switchport access vlan 10 ( bu portların vlan 10da hareket edebilir kılıyoruz)
console(config-if-vlan10)#exit (Aynı işlemi vlan 20 için yapıyoruz)
console(config)#ip routing ( vlanlara ip adresi vermişsek bu komutla birbiriyle haberleşir yani bu vlanlardaki pc ler birbirlerini artık pingleyebilir)

console#show startup-config (switch kapatılıp açıldığında conf duracak mı diye kontrol etmişte oluruz eğer burada boş çıkıyorsa write etmemişiz demektir)

2. Adım
console(config)# Sep 19 20:28:26 192.168.2.200-1 TRAPMGR[trapTask]: traputil.c(735) 355 %% INSERT_OPTICS: Optics SFP inserted in Te1/0/4 ( BURAYA CİBİK TAKILDI BUNU GÖSTERİYOR)
console(config)# Sep 19 20:28:38 192.168.2.200-1 TRAPMGR[trapTask]: traputil.c(735) 356 %% REMOVED_OPTICS: Optics SFP removed from Te1/0/4 ( BURAYA CİBİK SÖKÜLDÜ BUNU GÖSTERİYOR)

Sep 19 20:28:46 192.168.2.200-1 TRAPMGR[trapTask]: traputil.c(735) 357 %% INSERT_OPTICS: Optics SFP inserted in Te1/0/4 ( BURAYA CİBİK TAKILDI BUNU GÖSTERİYOR)
console#show interfaces transceiver properties ( Bu komut ile cibik lx mi sx mi bunu öğrenebilirsin)
console#show ninterfaces tengigabitethernet 1/0/1 (10GB PORTUN DURUMU)

3. ADIM
console(config)#stack (stack yapmak için gerekli komut)

console(config-stack)#stack-port tengigabitethernet 1/0/1 stack (Hangi portu stack yapacağını belirler bu işlem her stack sw de yapılmalıdır 1-2 yada 3-4 yapılabilir. Bunu yaptıktan sonra sw leri önce reboot etmek gerekiyor. Hangisi 1. Switch olacaksa onu önce açıp sonra diğerini açmak gereklidr.)

Warning: The modes of Te1/0/1 and pair port Te1/0/2 were changed to stack. (1 ve 2. 10gb portların stack yapıldığını söylüyor. Çapraz bağlantı şart olduğu için otomatik 2. Portu da yapıyor) console(config-stack)#exit

console#write console(config)#interface gigabitethernet 2/0/1 (birinci sw de iken artık ikinci sw yi de configure edebiliyorum)

console(config-if-Gi2/0/1)#interface vlan 10 (ikinci sw de vlan 10 a girdim. Dikkat etmek lazım burada tekrar vlan oluşturmadım. Vlan 10 dan taşıdı)
console(config)#interface range gigabitethernet 2/0/1-8 (ikinci sw de 1-8 arasını vlan 10 a member ettim) console(config-if)#switchport mode access
console(config-if)#switchport access vlan 10 (vlan 10 için 1-8 arasını kullanmasın izin verdim) console(config)# interface tengigabitethernet 1/0/3 (birinci switch in 10gb 3 portuna girdim)
console(config-if-Te1/0/3)#switchport mode trunk ( bu port trunk tır dedim)

console(config-if-Te1/0/3)#switchport trunk allowed vlan 10,20 (trunk olan porttan bu vlanlar geçebilir dedim.)

 

interface port-channel 10 (10 numara bir port channel oluşturduk)
switchport mode trunk
switchport trunk allowed vlan 10,20

interface Te1/0/1
channel-group 10 mode active
switchport mode trunk
switchport trunk allowed vlan 10,20
exit

interface Te1/0/2
channel-group 10 mode active (tengiga portlardan 10 numaları port channel grubunun geçebileceğini söyledik, bunu tengigaların karşısındaki switch üzerinde de yapmayı unutmamalıyız.)
switchport mode trunk
switchport trunk allowed vlan 10,20
exit

 

İşte hepsi bu kadar, network dünyası bir derya fakat %90 ihtimalle karşınıza gelecek ihtiyaçlar bunlardan ibaret olacaktır.

Sorularınız için: smuhacir [at] gmail.com

Şükür Muhacir

Leave a Comment

E-posta hesabınız yayımlanmayacak.